最新消息:

configure: error: failed to recognize APR_INT64_T_FMT on this platform

apr admin 10134浏览 1评论

在 MacOS 10.9 编译 subversion-1.8.9 时,出现

configure: error: failed to recognize APR_INT64_T_FMT on this platform

解决办法: 安装 Apache apr 和 apr-util

安装apr

wget http://mirrors.hust.edu.cn/apache/httpd/httpd-2.2.27.tar.gz
tar zxvf httpd-2.2.27.tar.gz
cd httpd-2.2.27/cd srclib/apr
./configure --prefix=/usr/local/apr
make
make install

安装apr-util

cd httpd-2.2.27/cd srclib/apr-util
./configure --prefix=/usr/local/apr-util
make
make install

重新编译安装 subversion-1.8.9 添加 apr 和 apr-util 参数

wget http://mirrors.hust.edu.cn/apache/subversion/subversion-1.8.9.tar.gz
tar zxvf subversion-1.8.9.tar.gz
cd subversion-1.8.9
./configure  --with-apr=/usr/local/apr --with-apr-util=/usr/local/apr-util/
make
make install

 

转载请注明:爱开源 » configure: error: failed to recognize APR_INT64_T_FMT on this platform

发表我的评论
取消评论
表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

网友最新评论 (1)

  1. 编译svn 1.11.1的朋友们请注意了,svn 1.11.1 以及1.9.10亲测都不兼容apr1.7.0,会报apr_int64_t_fmt这个错误,请编译apr1.6.5版本!!!!!!!!!!!!
    水母5个月前 (04-18)回复